In other words, when representing the concept of a foreign exchange rate in IDL, should the IDL interface be called ForeignExchangeRate or Foreign_Exchange_Rate? Similarly should a method to execute the trade be called executeTheTrade() or execute_the_trade()?
There are many stylistic issues that boil down to I think it looks better this way or that way. But from a development/maintenance cost perspective, these have little if any value. However there are some nits that can bite you if you choose one over the other.
If you expect to interoperate with Smalltalk, the underscore can create an ambiguity, particularly if you mix the two styles. For example, the IDL names execute_the_trade() and executeTheTrade() both are mapped into the Smalltalk name executeTheTrade(), which could create an ambiguity if the styles are mixed. In this case, it is best to avoid the underscores.
Similarly if you expect to interoperate with the C language, the IDL :: token is mapped to an _ in C, which can create ambiguities. In this case it is best to avoid the underscores.
Its a small point, to be sure, but it can catch up to you in the long run.
[ Top | Bottom | Previous section | Next section ]