U1 Organisatorisches

U1 Organisatorisches

B Tafelibungen: Windows-Umgebung
4 Raume 01.155-N und 01.153
# Integrierte Entwicklungsumgebung AVR Studio

B Rechneribungen (SPiC)
4 Raum 01.155
€ VVerwendung einer Windows-VM unter Linux

B Ziele der heutigen Tafellbung

1) Wie schreibe ich ein Programm unter Windows?

(

(2) Wie lade ich dieses Programm auf das Entwicklungsboard?

(3) Wie arbeite ich das Programm schrittweise ab (Fehlersuche/Debugging)?
(

4) Wie gebe ich eine Ubungsaufgabe ab (unter Linux)?
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U1-1 Login in die Windows-Umgebung

U1-1 Login in die Windows-Umgebung

B Zur Nutzung der Windows-PCs zunachst mit dem Kommando
/local/ciptools/bin/setsambapw
ein Windows-Passwort setzen.

» Achtung: Passwoérter werden erst nach etwa 10 Minuten aktiv!

B Setzen Sie jetzt soweit noch nicht geschehen im Raum 01.155 |hr
Windows-Passwort

B Melden Sie sich dann an der Windows-Domane ICIP an
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U1-2 Tafeliibung

U1-2 Tafelubung

B Keine Anwesenheitspflicht

B Es wird jedoch eine zufallig ausgewahlte Losung besprochen; bei
Abwesenheit gibt es gegebenenfalls 0 Punkte

# Gegebenenfalls vorher beim Ubungsleiter abmelden

B Fragen bitte im Forum der FSI EEI stellen:
® http://eei.fsi.uni-erlangen.de/forum/16
# Spezielles an i4spic@informatik.uni-erlangen.de
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U1-3 Rechneriibungen (SPiC)

U1-3 Rechnerubungen (SPiC)

B Termine:
¢ Mo 12:00-14:00
¢ Di 08:00-10:00
& Mi 14:00-16:00
¢ Do 10:00-12:00
¢ Fr 10:00-12:00

B Sonstiges:

® Wenn bis 30 Minuten nach Ubungsbeginn (hh:30 Uhr) keine Teilnehmer
anwesend sind, kénnen die Ubungsleiter die Rechnerilbung vorzeitig
beenden

4 In 01.155 sind Linux-Rechner. Es gibt daher die Moglichkeit in einer
Virtuellen Maschine unter Windows zu arbeiten. Alternativ ist auch das
Arbeiten unter Linux mdglich. Siehe Anhang.

@ Genaue Anleitung zur KVM auf der Webseite
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U1-4 Entwicklungsboards

U1-4 Entwicklungsboards

B 30 SPiC-Boards
4 ATmega32-Mikrocontroller (MCU)

B 22 Hardware-Debugger (grof3 mit 10-poligem Stecker)
# Entwicklung direkt auf den Boards
# Uberwachung des Programms wahrend der Ausfilhrung (Debugging)
@ Nutzung des Simulators entfallt
# Anschluss an den JTAG-Port des Boards

B 10 ISP-Programmer (klein mit 6-poligem Stecker)
@ kein Debugging maoglich
@ Anschluss an den ISP-Port des Boards

& USB-Kabel
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U1-4 Entwicklungsboards

U1-4 Entwicklungsboards

0 L

JTAG Anschluss

&
\ LED Reihe (active low)
LED 0 (Red 0, PD7)
LED 1 (Yellow 0, PCO ... il
LED 2 (Green 0, PC1) Stromversorgung

LED 3 (Blue 0, PC6)
LED 4 (Red 1, PC7)

LED 5 (Yellow 1, PA7)

i 7-Segment Anzeigen
LED 6 (Green 1, PA6
’ iner (Connector PD1)
LED 7 (Blue 1, PA

Zehner (Connector PD0)

(active low)
Potentiometer (POTI) an ADC1 |

ISP Anschluss

Fotowiderstand
an ADCO
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U1-5 SPiCboard-Bibliothek

U1-5 SPiCboard-Bibliothek

B Funktionsbibliothek zur einfachen Verwendung der Hardware
@ Konfiguration des Mikrocontrollers durch den Anwender entfallt

B Verwendung v. a. in der Anfangsphase

B Dokumentation zu den einzelnen Funktionen online verfugbar

http://www4.cs.fau.de/Lehre/SS11/V_SPIC/Uebung/doc
http://www4.cs.fau.de/Lehre/SS11/V_GSPIC/Uebung/doc
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U1-5 SPiCboard-Bibliothek

1 Projektverzeichnisse

B Spezielle Projektverzeichnisse zur Bearbeitung der Ubungsaufgaben
» Unter Linux: /proj/i4spic/login-Name
» Unter Windows: Laufwerk P:

B Aufgaben sollten ausschlieBlich im Projektverzeichnis bearbeitet werden

» Nur vom eigenen Benutzer lesbar
» Suchverzeichnis des Abgabeprogramms

B Werden nach Waffel-Anmeldung binnen eines Tages erzeugt

2 UNIX-Heimverzeichnisse

B Unter Windows: Laufwerk H:

B Zugriff auf Ihre Dateien aus der Linux-Umgebung

Systemnahe Programmierung in C — Ubungen U1.8
© Moritz Striibe, Michael Stilkerich ¢ Universitét Erlangen-Ndrnberg e Informatik 4, 2011 U1.fm 2011-05-11 09.23 :

Reproduktion jeder Art oder Verwendung dieser Unterlage, aufer zu L an der Universitit Erl Niirnberg, bedarf der des Autors



U1-5 SPiCboard-Bibliothek

Vorgabeverzeichnis

Unter Linux: /proj/i4spic/pub

Unter Windows: Laufwerk Q:

HE B B

Hilfsmaterial zu einzelnen Ubungsaufgaben

» z.B. /proj/idspic/pub/aufgabe0

B Testprogramm fur die Entwicklungsboards
» /proj/idspic/pub/boardtest

B Hilfsbibliothek (Board-Support-Package) und Dokumentation
» /proj/idspic/pub/i4

B Werkzeuge zur Entwicklung unter Linux
» /proj/idspic/pub/tools
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U1-6 Windows-Umgebung

U1-6 Windows-Umgebung

B Verwendung der Entwicklungsumgebung AVR Studio
& vereint Editor, Compiler und Debugger in einer Umgebung
4 komfortable Nutzung der JTAGICE-Debugger

1 Compiler

B Um auf einem PC Programme fir den AVR-Mikrocontroller zu erstellen,
wird ein Cross-Compiler benotigt

@ Ein Cross-Compiler ist ein Compiler, der Code fur eine Architektur generiert,
die von der Architektur des Rechners, auf dem der Compiler ausgefuhrt wird,
verschieden ist.

@ Hier: Compiler lauft auf Intel x86 und generiert Code fur AVR.
4 AVR Studio + WinAVR (Windows)
4 GNU Compiler Collection (GCC) unter Linux
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U1-6 Windows-Umgebung

2 AVR Studio

B Entwicklungsumgebung von Atmel
B Simulator und Debugger fur alle AVR-Mikrocontroller

B Start Gber das Startmeni
Start - Alle Programme - Atmel AVR Tools - AVR Studio 5.0
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U1-6 Windows-Umgebung

3 _AVR Studio einrichten (einmalig)

B Importieren des 14-Projekts (einmalig)
@ File -> Import Project Template
& Q:\tools\AVRStmpl.zip
4 Add to Folder: <Root>
& OK

B Importieren weiterer Einstellungen
@ Tools -> Import and Export Settings...
@ Import selected environment settings
@ No, just import new settings, overwriting my current settings
& Browse...
# Q:\tools\SPIC.vssettings
& All Settings
# Finish
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U1-6 Windows-Umgebung

3 Anlegen eines neuen Projekts

B Projekt erstellen
¢ File -> New -> Project...
# Projekt: SPiC
4 Name: aufgabeO
# Location: P:\
@ Kein Hakchen bei "Create directory for solution”
¢ OK

B Datei anlegen
@ View -> Solution Explorer (Ctrl + Alt + L)
& AufgabeX auswéhlen
# Project -> Add New Item... (Ctrl + Shift + A)
& C File
4 Name: Entsprechend der Aufgabenstellung
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U1-6 Windows-Umgebung

4 Erstellen einer main()-Funktion

B Auf dem Mikrocontroller ist die main()-Funktion vom Typ
void main (void) ;

» Sollte niemals zurtickkehren (wohin?)
» Ruckgabetyp daher nicht sinnvoll
» Freistehende Umgebung (-ffreestanding)

B Beispiel: Griine LED einschalten

#include <led.h>

void main(void) {
int i=0;
sb led on (GREENO) ;
while (1) { /* Endlosschleife*/
i++;
}

B Kompilieren des Programmes mit F7 oder Build - Build
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U1-6 Windows-Umgebung

5 Flashen des Programms auf die MCU (AVRISP)

B Mit dem Button: Flash ISP

B Alternativ:
@ Tools -> AVR Programming
¢ Tool: AVRISP
# Device: ATmega32
# Apply
@ Verbindung mit Device ID: Read Uberprifen
€ -> Memories
# Flash: P:\AufgabeX\Build\Programm.hex
4 -> Program
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U1-6 Windows-Umgebung

6 Starten des Simulators/Debuggers (JTAG)

B Debugger wahlen: Project -> Properties (ALT-F7)
¢ Debugging -> Select Debugger -> JTAGICE  |: 4 aTmega32 § AVR Simulator _

B Debug -> Start Debugging (F5) - Programm wird Ubersetzt und geladen
@ Das Programm wird zunachst beim Betreten von main () angehalten
4 Normal laufen lassen mit F5 oder Debug - Run
# Schrittweise abarbeiten mit

» F10 (step over): Funktionsaufrufe werden in einem Schritt bearbeitet
» F11 (step into): Bei Funktionsaufrufen wird die Funktion betreten

B Die I/0O-Ansicht (rechts) gibt Einblick in die Zustande der I/O-Register
@ Die Register konnen auch direkt geandert werden.

B Breakpoints unterbrechen das Programm einer bestimmen Stelle
@ Codezeile anklicken, dann F9 oder Debug - Toggle Breakpoint
€ Programm laufen lassen (F5), stoppt wenn ein Breakpoint erreicht wird
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U1-6 Windows-Umgebung

7 Starten des Simulators/Debuggers 2

P i b @ AT EE%E e @

Programm ausfuhren T T T

Programm anhalten

Debuggen beenden Funktion beenden

Reset Nachste Anw. (Funkt. Gberspingen)

Nachste Anweisung ausfihren

1@ Fvoid main(){
Breakpoint (setzen) —» §@ 11
12 |}

18 fHvoid main(}){
Aktueller Befehl — 110 ||  do_something();
12 }
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U1-7 Programm abgeben

U1-7 Programm abgeben

B Abgabeskript funktioniert nur in Linux-Umgebung

B Remote-Login auf den Linux-Rechnern
€ im StartmenU PuTTY starten
@ verbinden mit einem beliebigen Linux-Rechner, z. B. fauiosr0
* Von daheim: faui0sr0.cs.fau.de
& Gegebenenfalls speichern
@ Login mit den UNIX-Zugangsdaten

B Im Terminal-Fenster folgendes Kommando ausfihren:

/proj/id4spic/pub/abgabe aufgabel
# hierbei die aktuelle Aufgabe einsetzen
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U1-8 UNIX/Linux

U1-8 UNIX/Linux

B In der Ubung arbeiten wir mit der AVR-Studio-Umgebung unter Windows
@ Grundsatzlich gibt es auch die Mdglichkeit, unter Linux zu arbeiten
# In der Ubung nicht behandelt
@ Bei personlichem Interesse mogen die folgenden Informationen hilfreich
sein
# Ein Schnelleinstieg bedindet sich auf der Webseite
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U1-9 UNIX/Linux Benutzerumgebung

U1-9 UNIX/Linux Benutzerumgebung

B Kommandointerpreter (Shell)
» Programm, das Kommandos entgegennimmt und ausfuhrt
» verschiedene Varianten, am haufigsten unter Linux: bash oder tcsh

B Sonderzeichen
# einige Zeichen haben unter UNIX besondere Bedeutung
4 Funktionen:

» Korrektur von Tippfehlern
» Einwirkung auf den Ablauf von Programmen

M Ubersicht: (<CTRL> = <STRG> )
<BACKSPACE> letztes Zeichen l6schen (manchmal auch <DELETE>)
<CTRL>-C Interrupt - Programm wird abgebrochen
<CTRL>-Z Stop - Programm wird gestoppt (Fortsetzen mit £g)
<CTRL>-D End-of-File
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U1-9 UNIX/Linux Benutzerumgebung

1 Toolchain:
Vom Quellcode zum geflashten Binarabbild

(1) Erstellen des Programmaquellcodes mit einem Texteditor (z. B. vim oder kate)
& das Programm besteht ggf. aus mehreren Modulen ( = .c-Dateien )
4 und ggf. einer Schnittstellenbeschreibung/Header pro Modul ( = .h-Dateien )
¢ modulare Programmierung ist Gegenstand einer spateren Ubung

(2) Ubersetzen der C-Module zu Objektdateien mit einem C-Compiler (GCC)
# jedes C-Modul wird zu einer Objektdatei ( = .0-Datei ) kompiliert

4 da wir Binarcode fur den AVR erzeugen wollen, verwenden wir einen AVR-
Crosscompiler (avr-gcc)
avr-gcc -c¢ -o modul2.o modul2.c
(3) Linken/Binden der Objektdateien zu einem ladbaren ELF-Binarabbild (.elf-Datei)
4 mit GCC oder LD

avr-gcc -o program.elf modull.o modul2.o

(4) Flashen des Binarabbilds auf den Mikrocontroller
# z. B. mit avarice oder avrdude
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U1-9 UNIX/Linux Benutzerumgebung

2 Toolchain-Uberblick

moduli.c modul2.c C-Quelltext
‘ * Kompilieren
moduli.o modul2.0 AVR-Objektcode
* * Binden
program.elf o
* AVR-ELF Binarabbild
(program.hex)
Flashen
Systemnahe Programmierung in C — Ubungen U1.22
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3 Texteditoren
B verschiedene Editoren unter UNIX verflugbar
& vim
€ emacs
B fUr Einsteiger zu empfehlen: kate
& Starten
» durch Eingabe von kate in einer Shell
» oder uber Auswahlment von KDE
B Abspeichern der Quelltexte in Dateien mit der Endung .c im
Projektverzeichnis
@ die zu entwickelnden Module und Dateinamen sind in der Aufgabenstellung
vorgegeben
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4 Kompilieren der C-Module
B C-Quellcode wird mit einem C-Compiler (z. B. GCC) zu Binarcode fur die
Zielarchitektur (hier: 8-Bit AVR) Ubersetzt: avr-gcc
B Jede .c-Datei wird in eine Objektdatei Ubersetzt: Compileroption -¢
B Referenzen auf externe Symbole werden hierbei noch nicht aufgeldst
B Weitere Compiler-Flags
& -mmcu=atmega32: teilt dem Compiler den Typ der Ziel-CPU mit
# -ansi: wahlt den C-Standard ISO C90
& -Wall: aktiviert viele Warnungen, die auf evtl. Programmierfehler hinweisen
# -pedantic: aktiviert weitere Warnungen in Bezug auf ISO-C-Konformitat
4 -O0 bzw. -Os: Optimierungen deaktivieren bzw. nach GréBe optimieren
iz Debuggen mit -O0 -g, Testen mit -Os
B Ubersetzung eines C-Moduls modul.c dann zu modul.o mit Aufruf:

U1-9 UNIX/Linux Benutzerumgebung

avr-gcc -0Os -c -mmcu=atmega32 -ansi -pedantic -Wall modul.c
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U1-9 UNIX/Linux Benutzerumgebung

Binden der Objektdateien

Im Bindeschritt werden offene Symbolreferenzen aufgeldst

Binden z. B. mit avr-gcc

HE H BB O

Beispiel: Programm aus den Modulen modul1.o0 und modul2.0
€ mit avr-gcc (-0 bestimmt den Namen der Zieldatei, hier program.elf):

avr-gcc -mmcu=atmega32 -o program.elf modull.o modul2.o

B GCC kann auch in einem Schritt kompilieren und binden:

avr-gcc -mmcu=atmega32 ... -o program.elf modull.c modul2.c
# Vorteil: Ubersetzer sieht komplettes Programm = globale Optimierungen

* in aktuellen GCC Versionen: Compiler-Flags -combine -fwhole-program

@ Nachteil: Alle Module missen komplett Gbersetzt werden, auch wenn man
nur ein Modul verandert hat

# Fir kleine Programme ist diese Variante aber oft die bessere Wahl
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U1-9 UNIX/Linux Benutzerumgebung

6 Flashen des ELF-Images

B Ablegen des Binarabbilds im Flash-ROM des Mikrocontrollers
4 z. B. mit unserem Debugger und dem Programm avarice
4 wir haben das entsprechende Kommando in einem Makefile abgelegt
@ Beispiel: Flashen des Binarabbilds program.hex:
make -f /proj/i4spic/pub/i4/debug.mk program.hex.flash

B Nach jedem Reset ladt der Bootloader des Mikrocontrollers die
relevanten Sektionen in den RAM und startet die Ausfiihrung

M Fureinfache Programme (nur eine C-Datei program.c) Gbernimmt obiger
Aufruf zum Flashen auch die Ubersetzung
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U1-9 UNIX/Linux Benutzerumgebung

7 Debugging unter Linux (Hintergrundinfo)

B Der Debugger vereinfacht die Fehlersuche im Programm
# schrittweises Abarbeiten des Programms
@ Beobachten der Werte von Variablen
4 Haltepunkte (Breakpoints), auch abhéngig von Bedingungen

B Die JTAG-Debugger erlauben das Debugging der Ausfihrung direkt auf
dem Mikrocontroller

B Unter Linux ist das Debugging leider mit Schmerzen verbunden
@ Stepping durch den Code sehr langsam
& GDB-Stub stirzt gelegentlich ab
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U1-9 UNIX/Linux Benutzerumgebung

7 Anschluss des Debuggers

B Verbinden des Debuggers mit dem JTAG-Anschluss auf dem SPiCboard

B Board und Debugger an zwei USB-Ports des Rechners anschlie3en

@ Achtung: der Debugger funktioniert nicht zuverlassig an den SunRays,
daher "richtige" Rechner verwenden

B Das Programm avarice 6ffnet einen GDB-Stub und fungiert so als Mittler
zwischen JTAG-Debugger und Software-Debugger (avr-gdb)

B GDB-Stub-Rechner und Debug-Rechner sind normalerweise identisch
-7
TCP/IP

JTAG,  USB

00 -000-
ie
e —
= L} )
i y - /4
o 4
-

SPiCboard JTAG ICE GDB-Stub GDB-Debugger

avarice  avr-gdb| -
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U1-9 UNIX/Linux Benutzerumgebung

7 Verwendung des Debuggers

B Flashen des Binarabbilds program.elf in den Mikrocontroller

4 das Binarabbild sollte mit Debug-Symbolen erzeugt werden:
= zuséatzliches Compiler-Flag -g bei der Ubersetzung verwenden

4 Compiler-Optimierungen sollten deaktiviert werden: -O0

B Starten des GDB-Stubs avarice
make -f /proj/i4spic/pub/i4/debug.mk dbgstub

B Starten des Debuggers avr-gdb auf dem gleichen Rechner

avr-gdb program.elf

# Das hier verwendete Binarimage muss mit dem in den Mikrocontroller
geflashten Abbild Ubereinstimmen!

B Verbinden des Debuggers mit dem GDB-Stub

target remote localhost:4242

B Das Programm ist gestoppt an der ersten Instruktion
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7 Wichtige GDB-Kommandos

B Schrittweises Abarbeiten des Programms
4 n: fihrt n&chste Zeile C-Code aus, Ubergeht Funktionen
# s: wie n, steigt aber in Funktionen ab

B Setzen von Breakpoints (Haltepunkten)
@ Anzahl durch die Hardware auf 3 beschrankt
# b [Dateiname:]Funktionsname [condition]
& b Dateiname:Zeilennr. [condition]
4 Die Ausfuhrung stoppt bei Erreichen der angegebenen Stelle
4 wenn condition angeben (C-Ausdruck) nur dann, wenn Bedingung erfullt ist
# Breakpoints anzeigen: info breakpoints
@ Breakpoint I6schen (Nr. des Breakpoints aus Anzeige): d BreakpointNr

B Fortsetzen der Programmausfuhrung bis zu Haltepunkt: ¢
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7 Wichtige GDB-Kommandos

B Watchpoints: Stop der Ausfihrung bei Zugriff auf eine bestimmte Variable
& watch expr. Stoppt, wenn sich Wert des C-Ausdrucks expr andert
& rwatch expr. Stoppt, wenn expr gelesen wird
& awatch expr. Stoppt bei jedem Zugriff (kombiniert rwatch und watch)
@ expr ist ein C-Ausdruck, im einfachsten Fall der Name einer Variable

@ Achtung: fur jedes Byte des Ausdruks wird ein Hardware-Breakpoints
verbraucht, watch auf einen int belegt also zwei Hardware-Breakpoints!

B Weitere im Reference-Sheet (= Doku-Bereich der Webseite)
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